Everest - J2.5.27 + VM 2.6.12-cart update problem

4 years 9 months ago 4 years 9 months ago by .
MikeRiverra
Topic Author
Everest - J2.5.27 + VM 2.6.12-cart update problem #469
Hi,

You can access my platform on www.rozazu.ro to see how it works for now

As stated in topic name i'm setting up a new store on J2.5.27+VM 2.6.12 on YooEverest up to date theme.
Created some custom fields in VM for using with customs filtering component (search functionality).
For product update on site will use CSVI (5.18).

Installed vmuikit (first plugin, copied html folder in theme html , instaled component).

First issue found was vm_cart not functioning (unchecked Using the VirtueMart jQuery - and checked Load jQuery on MoWeb plugin - seems to have fixed the problem)
Second issue - cart update qty (+ or -) not working.
3rd issue - I cant't make "show cart" page look like the one in your demo:


mine looks like:


If I click checkout I'm missing fiels (as E-mail for guest checkout, etc) .. please make a test to see what I'm dealing with.

Can you help me fix my problems and make my shop look exactly like in your demo showcase for my theme and have the same functionality?

If needed I can create a test user with admin privileges on my backend for you.

Thank you,
Cosmin

Please Log in or Create an account to join the conversation.

4 years 9 months ago
Posts: 954
More
Everest - J2.5.27 + VM 2.6.12-cart update problem #472
I have sent you the One PAge Checkout plugin. It should take care of most of your problems there I think! Let us know! :-)
The following user(s) said Thank You MikeRiverra

Please Log in or Create an account to join the conversation.

4 years 9 months ago
MikeRiverra
Topic Author
Everest - J2.5.27 + VM 2.6.12-cart update problem #473
Thank you for being so fast :)

now I have some conflict between one page checkout plugin and my custom filter module.

saw in log these:
[Fri Nov 07 11:25:56.479015 2014] [fcgid:warn] ...........  mod_fcgid: stderr: PHP Strict Standards:  Only variables should be assigned by reference in ..../modules/mod_cf_filtering/helper.php on line 122, referer: mysite/rezultate/?custom_f_12[0]=3230352f3535523136
[Fri Nov 07 11:25:56.479019 2014] [fcgid:warn] ......... mod_fcgid: stderr: PHP Strict Standards:  Only variables should be assigned by reference in ......./modules/mod_cf_filtering/tmpl/default.php on line 32, referer: mysite/rezultate/?custom_f_12[0]=3230352f35355
[Fri Nov 07 11:26:24.574176 2014] [fcgid:warn].......................... mod_fcgid: stderr: PHP Notice:  Undefined variable: continue_link in .............../plugins/system/vmuikit_onepage/cart/cartview.html.php on line 1290, referer: mysite/produse/cart.html
[Fri Nov 07 11:26:24.574247 2014] [fcgid:warn] [pid 3172] [client 95.76.201.138:23466] mod_fcgid: stderr: PHP Notice:  Undefined offset: 1 in ..................../templates/yoo_nano3/html/mod_virtuemart_cart/default.php on line 93, referer: mysite/produse/cart.html

These all happens if I'm adding products to cart without logging in. If i disable any of the above no errors - so it must be a conflict between them.

If I'm shopping logged in, everything works as supposed to.

Any ideas?

Thank you,

Cosmin

Please Log in or Create an account to join the conversation.

4 years 9 months ago
Posts: 954
More
Everest - J2.5.27 + VM 2.6.12-cart update problem #476
Im more of the designer here so Im not the perfect guy to answer. Mani will have a look at this later to day too.

Bu one tips when it comes to conflicts is usually that there are several jQuery libraries loaded. To solve this I usually use Easy JQuery.

Its a free plugin that strips out all jquery and adds one that you choose. We recommend using 1.8.2 as it its the default one for Virtuemart 2.6.x series.

There is also a backward compatibility script in Easy Jquery you can enable to see if that helps.

Easy Jquery is free: www.simplifyyourweb.com/index.php/downlo...ory/8-loading-jquery

Its worth a try!

Please Log in or Create an account to join the conversation.

4 years 9 months ago
Posts: 1284
More
Everest - J2.5.27 + VM 2.6.12-cart update problem #479
Hello,

I see everything works good.

you are getting warning error from mod_cf_filtering module which not added by vmuikit.

try to disable error reporting in joomla backend to hide this error.

Thanks

Please Log in or Create an account to join the conversation.

4 years 9 months ago
MikeRiverra
Topic Author
Everest - J2.5.27 + VM 2.6.12-cart update problem #480
Hi,

Disabled J err reporting but still get the warnings unloged.

Can you help me get reed of them? They don't look pretty on the site.

Thank you,
C

Please Log in or Create an account to join the conversation.

4 years 9 months ago
Posts: 1284
More
Everest - J2.5.27 + VM 2.6.12-cart update problem #481
It means your server don't allow you to disable error reporting. please contact your server to hide it.

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum

Latest News from JoomlaPro.com

VMuikit 5 is finally out!

Our next version of our popular VMuikit package is out. This time we have some quite nice new features.

Electroneum Joomla/VirtueMart plugins

JoomlaPro.com are not only web & Joomla enthusiast, we cannot stay away from checking other tech trends as well. The last few years its been hard to miss the crypto/blockchain ...

New plugin: Secure Joomla Login

We have released a new plugin that adds a extra PIN code and a reCaptcha v2 check on Joomlas login. Security is very important on all fronts of a website. One often missed one is ...

We accept PayPal, 2Checkout & Electroneum payments:

We accept PayPal payments    We accept 2checkout payments  electroneum payment


For news and updates please like :